Primer removal and quality filtering in make.contigs

Hi, I’ve been using make.contigs (with a 4-column oligos file) in our pipeline for a while. I understand it has a lot of bells and whistles under the hood. Demultiplexing, removing primers, pair merging, etc.

I now have 2 questions.

  1. primer removal
    Our reads are longer than the amplicons. Therefore, R1 will extend into the reverse primer, and R2 will extend into the forward primer. Is there a clean way to handle this within make.contigs ? Right now, I have to call upon cutadapt on the merged reads out of make.contigs to remove those read-through primers

  2. quality filtering
    What exactly are the quality filtering parameters we can use/set within make.contigs? Insert, deltaq, maxee ?

The maxee is the same as that’s used with Vsearch ? does it have a default value in make.contigs ?

Do we have an option to set the minimum overlap length (as the -v parameter in PEAR) ?

The insert, is it the same as the -q parameter in PEAR (quality score threshold for
trimming the low-quality reads) ?

Thank you

Hi rjin - I think the best bet for trimming contigs where the reads extend into the opposite prime would be to use trimoverlap=TRUE. That option will only consider the regions with two reads per base. You can modify the insert, deltaq, etc. but I think you’ll find that the default values are pretty good. In our experience, ee has very little basis in reality. Also, I’d be reluctant to muck with any of these settings unless you have a mock community so that you know the “truth” for a set of sequences.


Thank you Pat !

  1. we tried trimoverlap=TRUE , and it worked in some cases. But it could be too aggressive sometime.

  2. I got your point on using the default value. For maxee , does it have a default value at all in make.contigs ? Or it’s not used unless we change the deltaq to 0 ? It was not clear in the wiki page

make.contigs wiki page

Thanks again

Hey - the maxee is not used by default. I think we probably have it set to a high value so that it isn’t used

Thanks Pat. That’s helpful to know…

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.