mothur

Make.lefse - [ERROR]: can't find Otu689 in constaxonomy file. Do the distances match, did you forget to use the label parameter?

#1

Hi Mothur team,

I am running into an error for make.lefse commmand:
ERROR]: can't find Otu689 in constaxonomy file. Do the distances match, did you forget to use the label parameter?.

I repeated my command using the same .shared file and .cons.taxonomy file for other treatment and they worked well. So, I am sure it is not because of the subsample problem. I debugged myself, but can’t get myself out. Can you please help check the problem? BTW, I don’t think it is mothur version or bug. I think it is my file problem, but I don’t have enough information to trace back ;(

Thanks for your Time!

Please find this link for Input file and mothur logfile

#2

Were the shared and the constaxonomy file generated using the same list and count file? Could you post the logfile with the commands you ran before the make.lefse command? I am specifically interested in the commands after the clustering steps.

#3

Hi Westcott,

Thanks for your time and helping with debugging! Yes, I used the same list and count file to generate the .shared and .constaxonomy file before I generate the .lefse file. Please find the commands I used before make.lefse in this link https://github.com/liufangbaishikele/Soybean_rhizosphere_microbiome/blob/master/2018_fungicide/Seed_treatment/lefse_debug_mothur.logfile. And I check the .constaxonomy file and the .shared file I used for make.lefse, their OtuID are the same. This Otu689 was not there in either files. More confusing is that I used the same .shared file and .constaxonomy file to generate .lefse file when subsetting other groups, it worked fine.

BTW, I did not try other version of mothur as the make.lefse command works for other group set.

Again, appreciate for your time help with debuging!

#4

When you set the groups parameter mothur removes any OTUs that do not contain reads from the groups listed. This is why the command may work with another set of groups. When I run the command with our latest version, which includes a modification for the OTU names, I am not seeing an error. Could you try the command with version 1.42, https://github.com/mothur/mothur/releases/tag/v1.42.0.

#5

Really appreciate for your time, Westcott! I will try Mothur 1.42 version and see how it goes.

closed #6

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.