make.contigs problem

I’m using mothur v.1.37.2 for MiSeq data.
When I run make.contigs with my trimmed fastq files (Q30) and the oligos file, it quit after a few minutes and I get an error message:

Input command:

make.contigs(ffastq=run141516_S1_L001_R1_001.trim.fastq, rfastq=run141516_S1_L001_R2_001.trim.fastq, oligos=AEFVY.oligos, bdiffs=1, pdiffs=2, processors=10)


Using 10 processors.
M01212_115_000000000-AEFVY_1_2105_5285_8428 is in your forward fastq file and not in your reverse file, please remove it using the remove.seqs command before proceeding.
Making contigs…
Segmentation fault: 11

I tried to run the command with the original fastq files thinking that the trimming didn´t go well, and I got empty files.


It took 5917 secs to process 21863596 sequences.

Output File Names: run141516_S1_L001_R1_001.trim.contigs.fasta run141516_S1_L001_R1_001.scrap.contigs.fasta run141516_S1_L001_R1_001.trim.contigs.qual run141516_S1_L001_R1_001.scrap.contigs.qual run141516_S1_L001_R1_001.contigs.groups
The oligos file seems to be OK, and I also tried to run the command with an older version of mothur (1.36.0), and I got the same output.

What do you think it can be happening?


It looks like the reverse read for that sequence was discarded due to low quality, but the forward one was retained. If you want to quality filter your sequences before running them through mothur, you’ll probably need to use an external quality filtering tool. sickle is quite good for this - when filtering paired reads if one direction fails, it automatically removes the partner so that your output files still contain matching forward/reverse sequences.

Can you run make.contigs with the raw fastq files? I have yet to see data suggesting that trimming prior to assembly improves anything.


Thanks you both for your answers.
I could run make.contigs with the raw files, but the output were empty files (zero bytes!).

The trimming that I did for both forward and reverse files, were:
trim.seqs(fasta=run141516_S1_L001_R1_001.fasta, qfile=run141516_S1_L001_R1_001.qual, qwindowaverage=35, qwindowsize=50, processors=8)

trim.seqs(fasta=run141516_S1_L001_R2_001.fasta, qfile=run141516_S1_L001_R2_001.qual, qwindowaverage=35, qwindowsize=50, processors=8)

After the trimming, in the forward file 20,737,859 out of 21,863,596 were retained. And in the reverse file 19,509,364 out of 21,863,596.

So, apparently I have enough sequences to make contigs, but is not working.
Do you think it will help doing the trimming with sickle or other?

Thanks again!

Are you using our current version 1.34.4?