get.otulabels with list file - error/bug?

Has anyone tried the get.otulabels command with an .otulabels file (generated from list.otulabels) and a list file?

I am trying to run this command in order to select 267 specific OTUs (e.g. OTU2, 17, 22, etc.) and the associated sequences from my list file.
I run get.otulabels(accnos=MaKno.otulabels, list=MaKno.list, label=0.03), but the sequences are not in their right OTUs anymore.

In MaKno.list
OTU1 Seq1,2,3,4
OTU2 Seq5,6,7,8
OTU16 Seq9,10,11,12
OTU17 Seq13,14,15,16

after running get.otulabels
OTU2 Seq13,14,15,16
OTU17 Seq 34,35,36,37

I want it to be
OTU2 Seq5,6,7,8
OTU7 Seq13,14,15,16
–>sequences are in the OTUs of the list file

Any suggestions or experience with this? The MaKno.otulabels file seems to be ok as get.otulabels(accnos=MaKno.otulabels, constaxonomy=MaKno.cons.taxonomy, label=0.03) works perfectly fine. The MaKno.list file is also ok because I can use it for other commands, such as make.shared, classify.otu, get.oturep , and the results are perfect.
The reason why I want to execute the get.otulabels command is that I want to create a rep.fasta file with the newly adjusted list file (only OTU2, 17, etc.) in get.oturep.

I appreciate any help!

PS: Alternatively I created a rep.fasta file with the original list file. Is there a way to only pick the wanted OTUs and create a new fasta?

I hope all of this makes sense. I appreciate any input! Thanks!

I am not able to reproduce the error you are describing with our current version. Are you using 1.36? Have you manually modified the list file?