count.seqs error: name-group mismatch

I’m just analyzing Miseq 16S data and following the SOP. I ran everything up to unique.seqs without problem. Then, I wanted to count the sequence, using name file (generated by the unique.seqs step) and the group file generated by screen.seqs (which removed ambiguous characters etc).

However, I get an error because "processes report xxx seqs, but group file indicates you have zzz seqs. I do not see how can I have a file mismatch, because nothing was generated inbetween. Also, when I ran the command with 20 processors, it reported an error and failed, while running it with processors=1, reported an error, but I still got a count file as an output.

So, now I am confused and don’t see where I could’ve missed something (I literally followed the SOP). And I think I’d need some help :slight_smile:

The version:
mothur v.1.39.5
Last updated: 3/20/2017


I think you can rerun it again and set the processors less. I faced the similar problem before. And I rerun it with fewer processors and finally, I got the right answer.

Good luck.

Sorry, my bad.
I overlooked that the screen.seqs command has a group option.

EDIT: no, the problem still persists.
I mean I filtered the group file with get.seqs, but I don’t know why it wasn’t filtered automatically?