cluster.split() too slow

When I run cluster.split(), our server has 8 processors, and I use 8 processors. Before this step. All the data run takes 24 hours. When came to this step, it has been run for 48 hours, and the system broke. Then I ran it again, from 0.dist to 4.dist not more than 1 hour, but the 5.dist is running very slowly.

Is there anything wrong with my data running?

Here is my code used:

cluster.split(fasta=stability.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.fasta, count=stability.trim.contigs.good.unique.good.filter.unique.precluster.denovo.vsearch.pick.pick.count_table,, splitmethod=classify, taxlevel=4, cutoff=0.03,processors=8)

You might also try taxlevel=5 or =6. Would also be good to know what your sequencing error rate is and how much RAM you have access to. What version of mothur are you using?


Hi. Dr. Schloss,

I am using a mothur 1.39.5. I am wondering is it rare or not for this kind of calculation speed?
My “stability.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.fasta.5.dist” file now is 7.9G now, and it is still changing larger. I am afraid.

Others are:
4.2G Oct 5 11:26 full.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.fasta.5.dist3411.temp
8.2G Oct 5 11:26 full.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.fasta.5.dist3412.temp
6.7G Oct 5 11:26 full.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.fasta.5.dist3413.temp
1.5G Oct 5 11:26 full.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.fasta.5.dist3414.temp
781M Oct 5 11:25 full.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.fasta.5.dist3415.temp
1016M Oct 5 11:26 full.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.fasta.5.dist3416.temp
1.5G Oct 5 11:26 full.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.fasta.5.dist3417.temp