cluster.split claims count file is missing sequences and refuses to merge files

I am running mothur v.1.35.1 on a remote server on USC.

I am running MiSeq with a fasta file and a count file.

I used 4 processors.

The command was as follows:

cluster.split(fasta=loihi.rename.chimerachecked.pick.fasta, count=loihi.rename.chimerachecked.pick.count_table,, splitmethod=classify, taxlevel=4, cutoff=0.15)

The clustering went fine, but at the file merging step, I got the following error:

Clustering loihi.rename.chimerachecked.pick.fasta.3.dist
Cutoff was 0.155 changed cutoff to 0.06
Cutoff was 0.155 changed cutoff to 0.08
Cutoff was 0.155 changed cutoff to 0.06
It took 280377 seconds to cluster
Merging the clustered files…
[ERROR]: loihi.rename.chimerachecked.pick.count_table.extra.temp is blank. Please correct.
[ERROR]: 102890G_1_21130.01 is not in your count table. Please correct.
[ERROR]: 20009 is not in your count table. Please correct.

I checked and neither of those files were in the original fasta.

When I ran dist.seqs with the same data, it turned out fine, but the distance matrix that came out was > 50 gb in size. I ran cluster, but it’s been 3 days and the process hasn’t finished, and I’m unsure if it’s still running or the server hung up. I need a .list file for get.otureps, and I need it within 2 weeks.


A few things…

  1. Please first update the version of mothur you are using. We sometimes solve bugs like these. It’s been more than a year since we released 1.35. Let us know if the problem persists.

  2. You really don’t want to use dist.seqs to generate a file for get.oturep. Try using the abundance option in get.oturep.