Cluster [ERROR]: expected a number and got OTU.141, quitting

I’m using mothur v.1.40.4. I generated a distance matrix using the dist.seqs command but when I try to cluster I get this error message.

[ERROR]: expected a number and got OTU.141, quitting…

Here’s the first few lines of my .dist:
OTU.141 aff3897fa18906e4264c1ada90530161 0.450593
OTU.141 bcfa9caeb61dbc47e2831c8876d454e8 0.454545
OTU.141 4cc7cccf90990459b7d7aac5584efc98 0.458498
OTU.141 432d5785299f460220f255c23b60c042 0.458498
OTU.141 aa41440508c3a7d91b4daf14910d1016 0.426877
OTU.141 d30003d611c3cb171b30534578aca7e4 0.458498
OTU.141 4d70285b21c1dc71272fdca37b01d460 0.478261
OTU.141 a8b913b911ad2daeeee784022d4577cf 0.470356
OTU.141 OTU.724 0.201581
OTU.141 OTU.679 0.209486
OTU.141 OTU.1429 0.205534
OTU.141 42b3defb8286115dfb7015a64d07c010 0.29249
OTU.141 OTU.205 0.193676
OTU.141 d7d39549f9245a56b1332479acf3d781 0.288538
OTU.141 2d2e58550e6db431a478c5062e57d8ae 0.29249
etc. etc.

What’s going on here? I thought the . in the OTU name might be an issue, but removing those doesn’t fix it. I know that numbered groups aren’t required, based on this example which contains U’s in the group names: column-formatted distance matrix

Your help is very much appreciated!

I fixed my own problem! It turns out cluster.classic expects a phylip formatted distance matrix. If you don’t specify method=“lt” in the dist.seqs function, you will get a column-formatted distance file which causes the clustering error.

Glad you got it resolved! FWIW- the version you are using is ~5 years old. I’d strongly encourage you to upgrade to the latest version:


Well, that’s not good! I’ve noticed that when I install mothur as a conda environment from this source that it downloads version 1.40.4, even though conda is entirely up to date. Here’s the output:

(mothur) cassi@ubuntu1804:~$ conda install -c bioconda mothur
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible so lve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done

It looks like maybe there is something wrong with the current_repodata.json and it’s defaulting to the next latest version?

Hmmm. I’m not sure quite what’s going wrong. Can you possibly try installing it with mamba and showing the error messages?

FWIW, in a fresh environment, I had to do…

$ mamba create -n mothur -c bioconda -c conda-forge mothur=1.48.0 libzlib

And things worked out ok. I initially got a complaint about libzlib being unavailable but adding it (and conda-forge) solved the problem


No problem, I was able to install the latest version of mothur via the source code. I just wanted to mention my issue with the conda installation in case other people run into the same problem and mistakenly think they are running the latest version.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.