chimera.uchime & classify.seqs - Segmentation Fault

I am getting segmentation fault errors on chimera.uchime and classify.seqs with mothur v1.33.3 “randomly” ( I do not see what is causing them at the moment) .
I am running this in galaxy on a cluster.
I have been trying to reproduce the error, without a lot of success.
Using the same set of data inputs and the exact same command line, would give the error sometimes, and sometimes not.
I tried to run it on different nodes of the cluster as well, it doesnt look to impact the happening of the error.
The team taking care of the cluster told me they did not change any software or hardware on the said cluster.
The best thing I found out is that there is a set of data giving me 100% of the time the error (this is with classify.seqs).
While another set of data would work a given day, and not the next one.
I am running out of ideas about this and any help would be really welcome here.

Apparently for classify.seqs, I do not get a segmentation fault if I run it without a count_table input.

EDIT : Also, i have 10 groups in my count_table file, in case it would make a difference

All right, so now I feel bad because the segfault i would get on classify.seqs 100% of the time was due to sequences being in my fasta file but not in my count_table.
So basicly i was using the wrong files for this dataset…

I still have some of this errors that i am unable to reproduce on chimera.uchime (and classify.seqs but that might be different).