mothur

AWS AWI Mothur 1.42 dll issue?

I have been trying to use the mothur-1.42.0 AMI but I get the following error when I try to launch mothur from the command prompt:

error while loading shared libraries:
cannot open shared object file: No such file or directory

And while you’re here…do you have advice for a utility that runs on a Windows 10 OS but creates files that can be uncompressed and read in a Linux environment? 7Zip?

Are you using the bash subsystem for windows or something like putty/cgwyn?

Here’s advice that I give before my workshops for installing the bash subsystem.

If you are running windows 10 and you have issues installing virtual box, you may want to try Bash on Windows 10 (https://www.howtogeek.com/249966/how-to-install-and-use-the-linux-bash-shell-on-windows-10/ or https://docs.microsoft.com/en-us/windows/wsl/install-win10) This should be a pretty straightforward install as long as you have admin access to your machine.

I’m using a Linux-based machine image available on Amazon Web Services. Perhaps this is my ignorance, but I thought that if I used PUTTY to SSH into the AMI, then I would be able to use Linux commands. This appeared to be the case for things such as moving up and down through directories. In the blog describing the use of the AMI, it stated that the mothur executable is in the path so you can just type “mothur” to execute this while in the home directory. When I tried to launch mothur, the error I got suggested that there was a problem with the links to the libraries, but that should be a problem in the machine image, not with my OS, correct?

I could try using an earlier version of the mothur AMI. Maybe this one is new enough that there are some bugs that have not been fixed yet.

ah sorry, I didn’t finish my answer. when I was mentioning the bash subsystem, I meant to use that to compress files for transmitting to aws.

I’ve never used mothur on aws. Do you need to use some sort of module system to make mothur avaliable to launch?

I’m following this tutorial on the wiki:
https://mothur.org/wiki/Mothur_AMI

I’m likely not proficient enough to give you enough useful information. I don’t even know what a module system is.

There are a number of mothur machine images on the AWS community AMIs which correspond to different releases of mothur. 1.42.0 is the latest and the next latest is 1.40.0. The machine image should contain the mothur executable along with sample data and reference databases for creating alignments or running chimera checker. The sudo functionality is not available for the image (unless you know the password) so I can’t really do much or even poke around.

Basically I login to my account on AWS and start an instance using this AMI. Then I use putty to ssh into the machine and transfer my files. I can see the directories in the AMI (data code) along with the files that I transferred. This is all I see when I use the ls command. Moving into the subdirectories I do not see where the mothur.exe is stored so I don’t know if this is just an error that I’m not in the correct directory to launch it? I’m a Windows user so I really don’t understand Linux well enough to troubleshoot.

sorry I can’t help, i’ve never tried that. Sarah or Pat will likely check the forum soon.

I tried the 1.40.0 AMI and it launches mothur with no issues. It must be an error in the 1.42.0 AMI?

As Erma Bombeck once said, “If you can’t be a good example, then be a horrible warning”.

I used mothur on a Windows machine to create a distance file and count table and then inputted these to the AWS AMI which is Linux. I wanted to do the clustering on the AMI since it was taking days on my personal computer. I naively thought that the output files could be read in either operating system, but that is not the case. So if you’re going to use the AWS AMI DO NOT switch from one operating system to another unless you know how to convert files from one to the other.

I’m now going to try to create an AWS Instance of a Windows server and upload the mothur.exe executable and my files to run the cluster analysis. I don’t know if this will work, but I hope I’ve provided some amusement to the much more computer literate members of this community :slight_smile:

personally, i’d start over on a linux aws

also, kudos for the bombeck quote

I’d strongly discourage using the windows server. It will be considerably slower and you’ll have to do a lot of figuring out on your own. Can you use the latest version of the mothur AMI and start again with the linux OS? For reproducibility concerns, I’d also back up @kmitchell’s suggestion of staring the pipeline from the beginning.

Pat

Hi Pat,

AWS does have a lot of excellent documentation for doing just about everything, including an entire section for connecting to Windows server workspaces (https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/connecting_to_windows_instance.html#rdp-prereqs). It took about 20 min following their guide to launch an instance, connect to it, map my drive to it, upload mothur and launch. It actually (embarrassingly) took me much longer to figure out PUTTY to transfer my files to the Linux server.

That being said, Windows does not have anything equivalent to the “screen” function in Linux so I would have to be connected the whole time. Also, being Windows, it’s much more circuitous to connect and transfer files than Linux (once I figured it out). Your advice is quite sound, but it’s being given to a pig-headed wannabe microbial ecologist who took it as a personal challenge to figure out how to run this on a Windows server :smiley: In retrospect, I should have done all my analyses on the mothur image from the beginning. I’ll remember that for next time!

Thanks for the help, and the excellent blog on the subject. Without that, I would have been too intimidated to even try using AWS!

Lisa

My reason for going against windows is that it is going to run slower and use memory in a weird way. Also, we haven’t totally worked out multi threading or gzip for windows. So if you stick with the AWS windows server you’ll really only be using one thread and won’t be able to read in gz files. If you’re going through the trouble of using AWS, I would strongly recommend using the linux version so that you can use the full memory allocation, get the speed bonus, and can use multiple threads. We have done our best to make mothur as OS agnostic as possible, but in the end it still runs better on OS X and linux.