mothur

Pcr.seqs [ERROR]: seqs are not aligned. When using start and end your sequences must be aligned

I am using Mothur version 1.46.1, within Ubuntu terminal for Windows10
I ran align.seqs with the silva138 reference alignment and the rrnDB fasta file

align.seqs(fasta=data/raw/rrnDB-5.7_16S_rRNA.fasta, reference=data/references/silva_seed/silva.seed_v138.align, flip=T)

This ran as expected, however pcr.seqs on the resulting .align file gave the error:

pcr.seqs(fasta=data/raw/rrnDB-5.7_16S_rRNA.align, start=1044, end=43116, outputdir=data/v19/)

[ERROR]: seqs are not aligned. When using start and end your sequences must be aligned.

I re-downloaded all the files and tried again with the same result

Hi ADL,

Can you post the output of running…

summary.seqs(fasta=data/raw/rrnDB-5.7_16S_rRNA.align)

Thanks,
Pat

Could you send the rrnDB-5.7_16S_rRNA.fasta file to mothur.bugs@gmail.com so I can take a closer look for you?

Have you tried running mothur natively on your Windows machine, https://github.com/mothur/mothur/releases/download/v1.46.1/Mothur.win.zip?

mothur > summary.seqs(fasta=data/raw/rrnDB-5.7_16S_rRNA.align)

Using 8 processors.

                Start   End     NBases  Ambigs  Polymer NumSeqs
Minimum:        1044    16429   569     0       4       1
2.5%-tile:      1044    43116   1401    0       5       230
25%-tile:       1044    43116   1437    0       5       2291
Median:         1044    43116   1464    0       6       4582
75%-tile:       1044    43116   1464    0       6       6873
97.5%-tile:     1044    43116   1475    0       7       8934
Maximum:        7922    43116   1576    4       9       9163
Mean:   1048    43111   1453    0       5
# of Seqs:      9163

It took 14 secs to summarize 9163 sequences.

Output File Names:
data/raw/rrnDB-5.7_16S_rRNA.summary

Sorry, the formatting is bad. But they sure look aligned

Ok, I’m running everything again with the most recent rrnDB files (5.7) and mothur version and now it appears to be working. I did nothing different. Every time before, the command for pcr.seqs terminated after a few seconds, with the error that the .align was not aligned. So I suppose my issue is resolved, but I’m not sure why.

Thanks for the update. Just to clarify, is it working using mothur’s windows version or are you still using the Ubuntu terminal on Windows?

It’s working on the Ubuntu terminal

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.