make.contigs no output in trim.contigs.fasta

Dear forum,

I’m analyzing 16s data from Miseq paired end illumina reads, and am stuck at the very first step of make.contigs. Following are the file I’m working with (total three):

  1. the forward read R1_001.fastq (contains no primers, adapter, barcode sequences, about 250bp per sequence)
  2. the reverse read R2_001.fastq (contains no primer, adapter, barcode sequences, about 250 bp per sequence)
  3. The index file (I1_001.fastq; contains barcode sequences only, in reverse complement form as only reverse primers were golay barcoded)

I have therefore used reverse.seqs for the I1.fastq file --> I1.rc.fastq)

Im using the following command:
make.contigs(ffastq=R1_001.fastq, rfastq=R2_001.fastq, rindex=I1_001.rc.fastq, oligos=sequences.oligos, bdiffs=1, pdiffs=2)

The oligos file is as follows:
primer forward_primer_sequence reverse_primer_sequence
barcode none barcode_sequence1 sample1
barcode none barcode_sequence2 sample2
barcode none barcode_sequence3 sample3

However, my problem is that trim.contigs.fasta file is blank at the end of the run. Additionally the scraps.contigs.fasta (which is the only file with any contents) have both |bf and |f endings.
Could anyone identify where Im going wrong? or what I should do differently?


I dont think reverse.seqs works with fastq files – when I tried, it just mangled the file into an unusable form. Why not just reverse complement the barcode sequences in the oligos file? It worked fine for me with some test data that way.

Wow, that was a great suggestion, it seems to have worked!