mothur

Libreadline6 Error

I am trying to run Mothur in an EC2 instance (Ubuntu18.04.2), but when I try to run it I receive this error: error while loading shared libraries: libreadline.so.6: cannot open shared object file: No such file or directory.

Things i’ve tried

  1. sudo apt-get install libreadline6 libreadline6-dev which returns:

Note, selecting ‘libreadline-dev’ instead of ‘libreadline6-dev’
Package libreadline6 is not available, but is referred to by another package.This may mean that the package is missing, has been obsoleted, or is only available from another source
E: Package ‘libreadline6’ has no installation candidate

  1. (https://mothur.org/wiki/how_to_resolve_readline_issues/) yum search readline which returns:

Warning: No matches found for: readline
No Matches found

This problem was addressed here (https://github.com/mothur/mothur/issues/571), and I have downloaded libreadline6, but do not know how to manually install into Ubuntu. Any adivce would be much appreciated!

If this is helpful, apt-file search readline/readline.h returns libreadline-dev: /usr/include/readline/readline.h libreadline-gplv2-dev: /usr/include/readline/readline.h

1.Download the missing readline (https://packages.ubuntu.com/xenial/libreadline6)
2.scp the file into your instance
3.sudo dpkg -i /path/to/deb/file

Worked for me!

Glad things worked out for you!
Pat

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.