mothur

Floating point exception when using processors=Autodetect

#1

Hello,

We have a user that is trying to run the pre.cluster step using the option processors=Autodetect and encountering the following error:

mothur > pre.cluster(fasta=stability.trim.contigs.good.unique.good.filter.unique.fasta, count=stability.trim.contigs.good.unique.good.filter.count_table, diffs=2, processors=Autodetect)
[ERROR]: Autodetect is not an integer. Setting processors to 36
[ERROR]: cannot convert Autodetect to an integer.
Floating point exception (core dumped)

Can you let us know if we are using this option incorrectly?

Thanks!

Carrie Brown

#2

Thanks for the question - we’ll look into it. For now, can you just set the number of processors to a specific value (e.g. 8)?

#3

Mothur is expecting an integer and does not recognize ‘Autodetect’. Mothur’s commands will automatically set the processors option to all processors found if you do not set it. So for example, if I have a machine with 4 processors, and run the command:

mothur > pre.cluster(fasta=stability.trim.contigs.good.unique.good.filter.unique.fasta, count=stability.trim.contigs.good.unique.good.filter.count_table, diffs=2)

Mothur will use 4 processors. Pre.cluster is a memory intensive command and you may need to reduce the number of processors to complete the command. I can set the processors to 2 as follows:

mothur > pre.cluster(fasta=stability.trim.contigs.good.unique.good.filter.unique.fasta, count=stability.trim.contigs.good.unique.good.filter.count_table, diffs=2, processors=2)